Documentation

​
​

Development

User Acquisition

Monetization

Industry

Asset Transformer Studio

2026.5.0

Supported
​

User Manual

Python API

Changelog

Asset Transformer Studio

2026.5.0

Supported
​

​
​
Get started
  • About Asset Transformer Studio
  • Getting started
  • Additional Resources
User Interface
  • Overview
  • Menu Bar
    • File Menu
    • Edit Menu
    • Create Menu
    • Selection Menu
    • Scene Menu
    • Materials Menu
    • CAD Menu
    • Mesh Menu
      • Repair Mesh
      • Remove Z-fighting
      • Vertex Offset
    • Optimize Mesh Menu
    • Point Cloud Menu
    • UVs Menu
    • Window Menu
    • Plugins Menu
    • Help Menu
  • Toolbars
  • Window
  • Customizing the User Interface
Data Preparation Fundamentals
  • Overview
  • General Information
  • Typical Data Preparation Workflow
  • About 3D Models Types
  • About the Product Structure (Tree)
  • About Occurrences
  • About Instances & Prototypes
  • About Face and Vertex Normals
  • About UVs
  • About Tessellation
  • About Decimation
  • About Animation
  • Glossary
Working With Asset Transformer Studio
  • Overview
  • Videos and Tutorials
  • Supported File Formats
  • Importing Files
  • Exporting Files
  • Scripting With the Python API
  • Interrupting a Process
  • Plugins
  • Errors in Asset Transformer Studio
Python API Reference
  • Overview
Changelog
  • Changelog
  1. Asset Transformer Studio
  2. User Interface
  3. Menu Bar

Mesh Menu

Asset Transformer Studio Mesh menu reference for repairing and manipulating meshes
Read time 3 minutes
Last updated 9 hours ago

Mesh Menu
The Mesh menu contains the most commonly used mesh data preparation algorithms:

Menu option

Description

Repair MeshAutomatically repairs selected meshes (tessellated geometries): stitches disconnected edges within the given tolerance, orients faces consistently
Orient FacesOrients consistently polygons' faces and normals in the same direction by propagating orientation information from one polygon to the other, for the selected meshes.
See About Face and Vertex Normals
Invert Faces OrientationInverts polygons' faces and normals orientation, for the selection. The selection can be either parts, patches or polygons.
Orient Faces From Current ViewOrient Faces From Current View executes a semi-automatic repair of polygons' face orientation, based on the viewport camera. It uses the camera's position to properly and automatically orient meshes faces toward its direction.

TIP: Use it step by step around your model until you are satisfied with mesh face orientation
Orient Faces (Advanced)Orients all polygon faces in the same direction, automatically and at once, on a full model, using a scattering of cameras to determine faces final orientation
Create NormalsCreates normals on the polygons of the selection
See About Face and Vertex Normals
Orient NormalsOrients consistently clockwise the vertex normals of a mesh in order to correct its smoothing
See About Face and Vertex Normals
Delete NormalsDeletes normals from a mesh

WARNING: Deleting normals from a mesh can result in an improper shading (black or faceted)
See About Face and Vertex Normals
Create TangentsCreates tangents on selected meshes, accordingly to their UVs (requires UVs in order to work)
Identify PatchesCreates patches boundaries on the selected meshes, based on geometrical information (attributes, edges angle, former CAD information…)
Delete PatchesDeletes patches boundaries
Explode Part By MaterialsCreates one Part occurrence by material applied on the patches of the selected parts
Explode Part By Connected MeshesSplits all the connected meshes within a Part into one new Part per connected mesh, for the selected parts
Explode Part By PatchesSplits meshes following patch boundaries and creates one single Part occurrence per old patch
Separate Selection in New PartCreates a new part out of a selection of submeshes (patches, polygons…)
Create LinesCreates polylines (made of free edges connected together) out of patches boundaries
Delete LinesDeletes polylines (made of free edges connected together)

TIP: It can be useful to delete lines prior to exporting to FBX files, in order to limit the file size and avoid performance issues in some cases.
Create Textures From LinesCreate textures out of coplanar polylines (made of free edges connected together)
Extract Neutral Axis From PipesCreate a polyline (or a group of polylines) out of any swept shape like pipes, wiring, tubing
Create Pipes From LinesExtrudes a circular section along an underlying polyline (sweep)
Delete Free VerticesDeletes all free vertices of a selection of meshes
Remove Z-fightingRemove Z-fighting (surfaces overlapping) by slightly shrinking the selected parts' surfaces
Vertex OffsetMoves the vertices by offsetting their position along their normal, positively or negatively

Copyright © 2026 Unity Technologies
LegalPrivacy PolicyCookiesDocumentation Terms of UseDo Not Sell or Share My Personal InformationYour Privacy Choices (Cookie Settings)

"Unity", Unity logos, and other Unity trademarks are trademarks or registered trademarks of Unity Technologies or its affiliates in the U.S and elsewhere (more info here). Other names or brands are trademarks of their respective owners.

Some pages are machine-translated for convenience, and may contain inaccuracies. In the event of conflicting information, the English version is authoritative.