Documentation

​
​

Development

User Acquisition

Monetization

Industry

Asset Transformer Studio

2026.5.0

Supported
​

User Manual

Python API

Changelog

Asset Transformer Studio

2026.5.0

Supported
​

​
​
Get started
  • About Asset Transformer Studio
  • Getting started
  • Additional Resources
User Interface
  • Overview
  • Menu Bar
    • File Menu
    • Edit Menu
    • Create Menu
    • Selection Menu
    • Scene Menu
    • Materials Menu
    • CAD Menu
    • Mesh Menu
    • Optimize Mesh Menu
    • Point Cloud Menu
    • UVs Menu
    • Window Menu
    • Plugins Menu
    • Help Menu
  • Toolbars
  • Window
  • Customizing the User Interface
Data Preparation Fundamentals
  • Overview
  • General Information
  • Typical Data Preparation Workflow
  • About 3D Models Types
  • About the Product Structure (Tree)
  • About Occurrences
  • About Instances & Prototypes
  • About Face and Vertex Normals
  • About UVs
  • About Tessellation
  • About Decimation
  • About Animation
  • Glossary
Working With Asset Transformer Studio
  • Overview
  • Videos and Tutorials
  • Supported File Formats
  • Importing Files
  • Exporting Files
  • Scripting With the Python API
  • Interrupting a Process
  • Plugins
  • Errors in Asset Transformer Studio
Python API Reference
  • Overview
Changelog
  • Changelog
  1. Asset Transformer Studio
  2. User Interface
  3. Menu Bar

Selection Menu

Asset Transformer Studio Selection menu reference
Read time 2 minutes
Last updated a day ago

Selection Menu
The Selection menu contains a set of functions to quickly and automatically select parts in the scene.
Warning
In Asset Transformer Studio, when a function requiring a selection of occurrences is executed with an empty selection, the whole scene will be processed. More information here.

Menu option

Description

Keyboard Shortcut

Select AllSelects all part occurrences (or parts) from the scene (visible and hidden)CTRL + A
Invert SelectionSwitches the current selectionCTRL + I
Clear SelectionClears the current selectionCTRL + SHIFT + A
Find Selection In TreeUsed to find the current selection in the Product Structure (Tree)CTRL + F
Isolate SelectionDisplays the current selection in a temporary view, in order to visualize it and process it independently from the whole sceneSPACE
Select AncestorSelects the first common ancestor of the current selection<
Select ChildrenSelects the children for each occurrence of the current selection>
Select Hidden PartsSelects all Parts not visible in the viewer (shown in the No-Show view), i.e. with their
Visible
property disabled.
Select Visible PartsSelects all Parts visible in the viewer
Select By Maximum SizeSelects Parts within a specified maximum Bounding Box diagonal size.
Identify by InstancesSelects Parts that are instantiated in the scene more than the specified value.
Select InstancesSelects all the instances of the currently selected occurrence (providing it is instantiated multiple times in the scene)
Select Similar PartsScans the entire scene to identify parts similar (geometrically identical) to the current selection (select Parts before using).
Select Duplicated PartsSelect duplicate parts, meaning identical parts that are superimposed (with similar size, polygon count, position and orientation).
NOTE: Requires tessellated objects (meshes): will not work with CAD/Brep objects.
Select Occluded PartsSelects Parts not viewed from a set of cameras placed spherically around the selection. Works the same way as the Hidden Removal function, but is not destructive (selects only).
NOTE: Requires tessellated objects (meshes): will not work with CAD/BRep objects.
Select Occluded Parts (Advanced)Selects Parts not viewed from a set of cameras automatically generated and scattered around the selected model.
NOTE: Requires tessellated objects (meshes): will not work with CAD/BRep objects.
Select By MaterialAllows you to select Parts from the scene that visually show a given material (independently from how the material is actually set, be it as a Material Property, applied to patches, or inherited from a parent)
Select By MetadataSelects all occurrences sharing an identical metadata property
Select By PropertyAllows you to select occurrences sharing an identical property, among the default properties like Name, Material or Visibility, or custom user-defined properties
Note
Advanced selection tools like
Select By Maximum Size
,
Select Parts from No Show
,
Identify Instances
,
Select Instances
and
Select Similar
will definitely ease and accelerate your data preparation processes in Asset Transformer Studio. Other "smart" selections can be achieved through Python scripting.

Copyright © 2026 Unity Technologies
LegalPrivacy PolicyCookiesDocumentation Terms of UseDo Not Sell or Share My Personal InformationYour Privacy Choices (Cookie Settings)

"Unity", Unity logos, and other Unity trademarks are trademarks or registered trademarks of Unity Technologies or its affiliates in the U.S and elsewhere (more info here). Other names or brands are trademarks of their respective owners.

Some pages are machine-translated for convenience, and may contain inaccuracies. In the event of conflicting information, the English version is authoritative.