Documentation

​
​

Development

User Acquisition

Monetization

Industry

Asset Transformer Studio

2026.5.0

Supported
​

User Manual

Python API

Changelog

Asset Transformer Studio

2026.5.0

Supported
​

​
​
Get started
  • About Asset Transformer Studio
  • Getting started
  • Additional Resources
User Interface
  • Overview
  • Menu Bar
    • File Menu
    • Edit Menu
    • Create Menu
    • Selection Menu
    • Scene Menu
    • Materials Menu
    • CAD Menu
    • Mesh Menu
    • Optimize Mesh Menu
      • Generate LOD Chain
    • Point Cloud Menu
    • UVs Menu
    • Window Menu
    • Plugins Menu
    • Help Menu
  • Toolbars
  • Window
  • Customizing the User Interface
Data Preparation Fundamentals
  • Overview
  • General Information
  • Typical Data Preparation Workflow
  • About 3D Models Types
  • About the Product Structure (Tree)
  • About Occurrences
  • About Instances & Prototypes
  • About Face and Vertex Normals
  • About UVs
  • About Tessellation
  • About Decimation
  • About Animation
  • Glossary
Working With Asset Transformer Studio
  • Overview
  • Videos and Tutorials
  • Supported File Formats
  • Importing Files
  • Exporting Files
  • Scripting With the Python API
  • Interrupting a Process
  • Plugins
  • Errors in Asset Transformer Studio
Python API Reference
  • Overview
Changelog
  • Changelog
  1. Asset Transformer Studio
  2. User Interface
  3. Menu Bar

Optimize Mesh Menu

Asset Transformer Studio Optimize Mesh menu reference
Read time 2 minutes
Last updated a day ago

Optimize Mesh Menu
The Optimize Mesh menu contains advanced mesh data optimization/reduction algorithms:

Menu option

Description

Remove HolesRemoves holes from the meshes of the selected parts, or fills them with a specified material.
See also: Remove Holes in Asset Transformer SDK documentation
Decimate To QualityReduces meshes density (polygon count) on the selected parts by performing a decimation algorithm.
See also: About Decimation
Decimate To TargetReduces the polygon density targeting the triangle count defined by the user.
See also: About Decimation
Generate LOD ChainAutomatically generates 3 LODs for the current selection.
See also: Generate LOD Chain
Remove Occluded GeometriesAutomatically deletes parts, patches or polygons not viewed from a set of cameras placed spherically around the selected parts.
See also: Remove Occluded Geometries in Asset Transformer SDK documentation
Remove Occluded Geometries (Advanced)Automatically deletes parts, patches or polygons not viewed from a set of cameras automatically generated and scattered around the selected model.
See also: Remove Occluded Geometries (Advanced) in Asset Transformer SDK documentation
Generate Phantom MeshAutomatically generates one unique optimized mesh out of the models in the scene, with materials
Proxy Mesh + BakeAutomatically generates a proxy mesh (or remeshing) out of the current selection, with optional automatic texture maps generation (by baking)
Decimate To Target + BakeAutomatically decimates a selection of meshes, using as a target a triangle count or a ratio (reduction percentage), and bakes Normals information into a texture (plus other textures).
Create BillboardCreate a billboard (textured planes) out of a selection of parts
VoxelizeAutomatically generates a voxelization representation out of the external skin of the selected parts
Marching CubesAutomatically generates a marching cubes representation out of the meshes of the selected Parts
Convex DecompositionCreates a new set of convex meshes approximating the given meshes
Proxy MeshAutomatically generates a proxy mesh (or remeshing) out of the current selection
Replace ByUse to replace a selection of occurrences with another occurrence, its Bounding Box, a Convex Hull envelop or a primitive
Bake Texture MapsCreate textures maps (map types: Diffuse, Normal, Opacity, Roughness, Specular, Metallic, AO, Part ID, Material ID…) out of the selected parts, providing they have normalized UVs.

TIP: By default, maps are baked with a padding (or "dilation") of a few pixels, defined in the
Padding
parameter. It is also possible to bake maps with an "infinite" padding, in order to avoid issues like mipmap bleeding when seeing a model from a distance. To do so, set the value in the Padding parameter to
-1
.
Combine Materials in TexturesCombines materials into one baked material, assigned to the selection (no parts merging)

Copyright © 2026 Unity Technologies
LegalPrivacy PolicyCookiesDocumentation Terms of UseDo Not Sell or Share My Personal InformationYour Privacy Choices (Cookie Settings)

"Unity", Unity logos, and other Unity trademarks are trademarks or registered trademarks of Unity Technologies or its affiliates in the U.S and elsewhere (more info here). Other names or brands are trademarks of their respective owners.

Some pages are machine-translated for convenience, and may contain inaccuracies. In the event of conflicting information, the English version is authoritative.