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開始直後にビルドがキャンセル

Resolve issues with Unity Build Automation builds canceling immediately upon start.
読み終わるまでの所要時間 1 分最終更新 1ヶ月前

事象

  • Unity Build Automation (UBA) サービスでビルドがトリガーされると、ビルドは即座にキャンセルされます。
  • 新しいビルドは UBA を使用して開始できません。
  • 新しいビルドのトリガー時に UBA はログを作成しません。

環境 /Environment

Build Automation の設定ページまたは Unity Dashboard のビルド履歴のいずれかからビルドを起動すると、ビルドがトリガーされると直ちにキャンセルされます。

原因

この問題の最も一般的な原因は以下の通りです。
  • その組織は Free DevOps プラン を使用しており、ビルドが利用可能な無料使用量を超えたため、使用量に基づくプラン に変換する必要があります。
  • ビルドの時間上限があり、ビルドを開始すると、事前に設定された使用上限を超えてしまいます。
  • ビルド設定が無効です。例えば、ソース管理への接続が利用できない、または Xcode バージョンが利用できないなどが挙げられます。

解決方法

従量課金制プランへの変更

Unity Cloud Dashboard の DevOps メニューで、以下のスクリーンショットに示すように、ダッシュボードに、使用量に基づいたプランではなく 無料プラン と表示されている場合は、使用量に基づいたプランに登録できます。サービスにサインアップするには、Unity Dashboard > DevOps > Upgrade plan (プランのアップグレード) を選択します。
"UBA - 従量課金"

UBA - 従量課金

ビルドの時間上限の変更

有効なサブスクリプションがある場合、次はビルドの時間上限があるかどうか、ビルドがその上限を超えているかどうかを確認します。Unity Dashboard で確認するには、DevOps > Build Automation > Settings (設定) に移動し、Build Consumption (ビルド使用量) タブを選択します。 Build minutes monthly cap (ビルド時間 (分) 月間上限) が有効で、制限に近づいている場合は、上限を無効にするか増やすことでサービスを引き続き使用できます。
"UBA - 月間上限の管理"

UBA - 月間上限の管理

サポートチームへの問い合わせ

プランとビルドの時間上限が検証済みで、現在サービスに問題が報告されていない場合は (DevOps メニューの Build Automation サイドバーに表示されます)、サービスサポートチームに問い合わせてください。Unity Cloud Dashboard からチケットを送信するには、DevOps を開き、Help & Support (ヘルプとサポート) > Ticket (チケット) > File a ticket (チケットの提出) を選択します。