Visual Studio C# インテグレーション
Set up and use Microsoft Visual Studio as your default script editor for Unity.
読み終わるまでの所要時間 5 分最終更新 1ヶ月前
Unity は、Code Editor Package for Visual Studio を通じて Microsoft Visual Studio と統合されます。このパッケージは、Unity のインストール時にプリインストールされます。Unity のインストール時にすでに Visual Studio がインストールされている場合、Unity はデフォルトで Visual Studio を使用してスクリプトの起動と編集を行います。

Package Manager ウィンドウに表示された Visual Studio Editor
Visual Studio をデフォルトのスクリプトエディターとして設定する
Unity のインストール時にすでに Visual Studio がインストールされている場合や、Unity のインストールの一環として Visual Studio をインストールした場合は、Unity は自動的に Visual Studio をデフォルトのスクリプトエディターとして使用します。Visual Studio は、既存の Unity インストールにモジュールとしてインストールすることができます。詳細については、Unity Hub を使用してエディターやモジュールをダウンロードおよびインストールする を参照してください。
以下の手順で、デフォルトのスクリプトエディターを手動で設定できます。
- メインメニューで Edit > Preferences (macOS: Unity > Settings) の順に選択し、Preferences ウィンドウを開きます。
- External Tools メニューを開きます。
- External Script Editor ドロップダウンメニューをクリックし、Microsoft Visual Studio を選択します。このオプションの見た目は、インストールされている Microsoft Visual Studio のバージョンによって変化します。

External Tool 設定
A: External Script Editor ドロップダウンメニューには、選択されたスクリプトエディターの名前とバージョンが表示されます。
B:選択されたスクリプトエディターと統合される Unity パッケージの名前とバージョンが表示されます。
Unity は Visual Studio の C# コンパイラーを使用してスクリプトをコンパイルします。Visual Studio とともに Visual Studio Editor パッケージを使用すると、Unity と Visual Studio の両方に、スクリプト内のすべてのエラーの詳細が表示されます。
Unity は Visual Studio の .sln ファイルと .csproj ファイルの作成と管理を自動で行います。Preferences ウィンドウの External Tools メニュー (上の画像) で、Unity がプロジェクトの特定の要素の .csproj ファイルを生成するかどうかを制御できます。各要素のチェックボックスの有効/無効を切り替えると、Unity がその特定のオプションの .csproj ファイルを生成するかどうかが切り替わります。
誰かが (例えば既存のファイルの編集や新しいファイルの作成など) ファイルの状態を変更するたびに、Unity がプロジェクト内の .sln ファイルと .csproj ファイルを再生成します。また、Visual Studio からソリューションにファイルを追加することもできます。Unity は新しいファイルをすべてインポートし、次にプロジェクトファイルを再度作成する時に、それらの新しいファイルを含めて作成します。