Linux IL2CPP クロスコンパイラー
Linux IL2CPP クロスコンパイラーを使用すると、Linux Unity エディターや Mono に依存することなく、あらゆるスタンドアロンプラットフォームで Linux IL2CPP プレイヤーをビルドできます。
読み終わるまでの所要時間 8 分最終更新 3日前
Linux IL2CPP クロスコンパイラーは、sysroot パッケージとツールチェーンパッケージのセットです。これを使用すると、Linux Unity エディターを使用したり Mono に依存することなく、任意のスタンドアロンプラットフォームで Linux IL2CPP プレイヤーをビルドできます。
要件を満たしている場合、Linux ビルドターゲットを選択すると、Unity が自動的にこれらのパッケージをインストールします。このプロセスをオプトアウトして独自の sysroot パッケージとツールチェーンパッケージを使用する場合は、編集> > Toolchain Management に移動し、Install Toolchain パッケージ自動インストールチェックボックスを使用不可にします。これらをすでにインストールしている場合は、Package Manager から削除する必要もあります。
プロジェクト設定
?
前提条件
Unity が IL2CPP コンパイラーパッケージをインストールするには、以下の必要です。
- 選択した Linux ツールチェーン パッケージに十分なディスク スペース。詳細については、Linux ツールチェーンパッケージに必要なディスクスペース を参照してください。
- スクリプト終了を IL2CPP に設定スクリプト終了を IL2CPP に設定するには、以下を行います。編集> Project Settings> Player Settings for Linux> Other Settings> 設定に移動します。をスクリプティングバックエンド:
?
に設定します。IL2CPP?
- IL2CPP モジュールIL2CPP モジュールのインストール方法については、モジュールの追加 に記載されている手順を参照してください。
Linux sysroot パッケージ
Linux sysroot パッケージは、Linux 用のビルドに必要なすべてのヘッダーとライブラリを含むディレクトリです。
すべてのオペレーティングシステム (OS) には、それぞれ独自のビルドシステムがあり、ビルドシステムは異なります。特定の OS のヘッダーとライブラリを使用してビルドする場合、ビルドされたプレイヤーは他のオペレーティングシステムでは実行されない可能性があります。これに対処するために、Unity は、サポートされているすべての Linux プラットフォームで動作するビルド用の sysroot を提供しています。
Linuxツールチェーンパッケージ
Unity は、macOS、Windows、Linux 用のツールチェーンパッケージを提供しています。これらのプラットフォームは、それぞれ一意の方法で Linux 用に構築されます。
Linuxツールチェーン パッケージは、Unityがこれらの各オペレーティング システムからLinux用にビルドするために必要なツール セット(コンパイラーおよびリンカーを含む)です。
Linux ツールチェーンパッケージに必要なディスクスペース
パッケージのダウンロード、解凍、使用をアカウントして、十分なディスクスペースを確保してください。
まれに、十分なスペースがあるかどうかわからない場合は、 環境変数を定義し、それを使用して解凍した sysroot とツールチェーンのパッケージを保存します。環境変数は、Unity の外部で設定する変数で、Unity がリファレンスに使用できます。この場合、sysroot パッケージとツールチェーンパッケージを解凍するときに Unity がリファレンスできるキャッシュを設定します。環境変数はオペレーティング システムに固有であるため、システムのガイドラインに従って設定する必要があります。
UNITY_SYSROOT_CACHE以下の表は、各ツールチェーンパッケージに必要な合計ディスクスペースを示しています。
Toolchain パッケージ | 必要なディスクスペース |
|---|---|
| 5 MB |
| 120 GB |
| 120 GB |
Linux IL2CPP クロスコンパイラーの使用
このページのすべての要件を満たしている場合は、Linux プレイヤーとしてプロジェクトをビルドできます。Unity はビルド時に Linux IL2CPP クロスコンパイラーを自動的に使用します。
Linux プレイヤーをビルドするには、次の手順に従います。
- ビルドプロファイルウィンドウ (メニュー:ファイル> ビルドプロファイル)。
- 「**プラットフォーム」**パネルのプラットフォームのリストから、Linux を選択するか、Linux プラットフォーム用のビルドプロファイルを作成します。
- スイッチ プラットフォームを選択します。
- ビルドまたはビルドと実行を選択します。
追加リソース
- Unity エディターでのモジュールの追加方法
- Linux ビルド設定リファレンスプラットフォームドキュメント。
- Linuxプレイヤー設定
- IL2CPP 追加引数リファレンス