기술 자료

Unity Engine

Unity Engine

Visual Studio C# 통합

Set up and use Microsoft Visual Studio as your default script editor for Unity.
읽는 시간 2분최근 업데이트: 한 달 전

Unity는 Visual Studio용 Code Editor 패키지를 통해 Microsoft Visual Studio와 통합됩니다. 이 패키지는 Unity를 설치할 때 미리 설치됩니다. Unity를 설치할 때 Visual Studio가 설치되어 있는 경우 Unity는 기본적으로 Visual Studio를 사용하여 스크립트를 열고 편집합니다.

패키지 관리자 창에 있는 Visual Studio Editor

Visual Studio를 기본 스크립트 에디터로 설정

Unity를 설치할 때 Visual Studio가 설치되어 있거나 Unity 설치 프로세스의 일환으로 Visual Studio를 설치하는 경우 Unity는 자동으로 Visual Studio를 기본 스크립트 에디터로 사용합니다. Visual Studio를 기존 Unity 설치에 모듈로 설치할 수 있습니다. 자세한 내용은 Unity Hub를 사용하여 에디터 및 모듈 다운로드 및 설치를 참조하십시오.
기본 스크립트 에디터를 수동으로 설정하려면 다음 단계를 따르십시오.
  • 메인 메뉴에서 Edit > Preferences(macOS: Unity > Settings)로 이동하여 Preferences 창을 엽니다.
  • External Tools 메뉴를 엽니다.
  • External Script Editor 드롭다운을 클릭하고 Microsoft Visual Studio를 선택합니다. 이 옵션의 모습은 설치한 Microsoft Visual Studio 버전에 따라 달라집니다.

External Tool 설정

A: 선택한 스크립트 에디터의 이름과 버전을 표시하는 External Script Editor 드롭다운 메뉴
B: 선택한 스크립트 에디터와 통합되는 Unity 패키지의 이름 및 버전
Unity는 Visual Studio의 C# 컴파일러를 사용하여 스크립트를 컴파일합니다. Visual Studio Editor 패키지를 Visual Studio와 함께 사용하면 Unity와 Visual Studio 모두에 스크립트의 모든 오류에 대한 세부 정보가 표시됩니다.
Unity는 Visual Studio .sln 및 .csproj 파일을 자동으로 생성하고 관리합니다. 위 스크린샷처럼 Preferences 창의 External Tools 메뉴에서 Unity가 프로젝트의 특정 요소에 .csproj 파일을 생성하는지 여부를 제어할 수 있습니다. 체크박스를 활성화하거나 비활성화하여 Unity가 특정 옵션에 .csproj 파일을 생성하는지 여부를 토글합니다.
Unity는 기여자가 기존 파일을 편집하거나 새 파일을 생성하는 등 파일 상태를 변경할 때마다 프로젝트의 .sln 및 .csproj 파일을 다시 생성합니다. Visual Studio에서 솔루션에 파일을 추가할 수도 있습니다. Unity는 새 파일을 임포트하고 다음에 Unity가 프로젝트 파일을 다시 생성할 때 새 파일이 포함된 파일을 생성합니다.