ドキュメント

Unity Engine

Unity Engine

ログファイルリファレンス

Locate Unity's log files which record messages, warnings, and errors that can help you understand the source of problems in your application.
読み終わるまでの所要時間 8 分最終更新 1ヶ月前

Unityは、Editor、Package Manager、ライセンス、開発プレイヤー、Hub のログファイルを生成します。これらのログファイルを使用して、アプリケーションのどこで問題が発生したかを把握できます。
Unity は、コンソールウィンドウのメッセージ、警告、エラーをすべてログファイルに追加します。コンソールウィンドウに独自のメッセージとログを追加するには、デバッグクラスを使用します。
各オペレーティングシステムは、異なる場所にログファイルを保存します。このページでデフォルトの場所について概説しますが、特定のコマンドライン引数を使用して、Unity がログファイルを生成するタイミングと場所をコントロールすることもできます。詳細については、コマンドライン引数のドキュメントを参照してください。
注意すべてのプラットフォームでこの機能がサポートされているわけではありません。詳細については、プラットフォーム固有のドキュメントを参照してください。
コンソールウィンドウからエディターログにアクセスできます。これを行うには、コンソールウィンドウ (メニュー: Window > General > Console) を開き、コンソールウィンドウのメニューから Open Editor Log を選択します。
オペレーティングシステムのファイルマネージャーアアプリケーションを使用して、他のログにアクセスできます。

Linux

ログタイプ

ログの場所

Editor
~/.config/unity3d/Editor.log
Package manager
~/.config/unity3d/upm.log
クライアントのライセンス管理
~/.config/unity3d/Unity/Unity.Licensing.Client.log
ライセンス監査
~/.config/unity3d/Unity/Unity.Entitlements.Audit.log

macOS

macOSでは、Console.app ユーティリティを使用して Unity のログにアクセスすることもできます。

ログタイプ

ログの場所

Editor
~/Library/Logs/Unity/Editor.log
Package manager
~/Library/Logs/Unity/upm.log
クライアントのライセンス管理
~/Library/Logs/Unity/Unity.Licensing.Client.log
ライセンス監査
~/Library/Logs/Unity/Unity.Entitlements.Audit.log

Windows

Windows では、Package Manager とエディターのログは、デフォルトでは Windows エクスプローラーに表示されないフォルダーに配置されます。AppData フォルダーを表示するには、Windows で Hidden Items (隠しアイテム) 設定を有効にする必要があります。これを行う方法の詳細については、Windows の隠しファイルと隠しフォルダーの表示に関する Microsoft のドキュメントを参照してください。
Windows では、標準出力ストリームはデフォルトでは存在しないため、CI システムから子プロセスとして、有効な設定済み
stdout
ストリームでエディターを起動する必要があります。
stdout
に出力 ``を送信するように
-
に対して指定すると、コンソール ウィンドウに出力が表示されません。

ログタイプ

ログの場所

Editor
%LOCALAPPDATA%\Unity\Editor\Editor.log
Package managerユーザーアカウント:
%LOCALAPPDATA%\Unity\Editor\upm.log

SYSTEM アカウント:
%ALLUSERSPROFILE%\Unity\Editor\upm.log
クライアントのライセンス管理
%LOCALAPPDATA%\Unity\Unity.Licensing.Client.log
ライセンス監査
%LOCALAPPDATA%\Unity\Unity.Entitlements.Audit.log
クラッシュファイル
%TMP%\CompanyName\ProductName\Crashes


注意フォルダーの場所は、
-crash-report-folder
コマンドライン引数で上書きできます。
プレイヤーログを表示するには、コンソールウィンドウ (メニュー: Window > General > Console) を開き、コンソールウィンドウのメニューから Open Player Log を選択します。また、以下のフォルダーに移動することもできます。

OS

プレイヤーログの場所

AndroidAndroid アプリケーションのプレイヤーログにアクセスするには、Android Logcat を使用します。詳細については、Android ログの表示を参照してください。
iOSiOS デバイスのログにアクセスするには、GDB コンソールまたは XCode の Organizer コンソールを使用します。デバイスログの詳細については、Apple のドキュメントを参照してください。
Linux
~/.config/unity3d/CompanyName/ProductName/Player.log
macOS
~/Library/Logs/Company Name/Product Name/Player.log


注意Console.app ユーティリティを使用してログ ファイルを検索することもできます。
ユニバーサル Windows プラットフォーム
%USERPROFILE%\AppData\Local\Packages\<productname>\TempState\UnityPlayer.log
WebUnity はログ出力をブラウザーの JavaScript コンソールに書き込みます。
Windows
%USERPROFILE%\AppData\LocalLow\CompanyName\ProductName\Player.log

Unity Hub ログの場所

Hub ログには、オペレーティングシステムのファイルマネージャーアアプリケーションを使用してアクセスできます。これらのログには、Hub 内からもアクセスできます。詳細については、Hub に関するドキュメントを参照してください。

OS

プレイヤーログの場所

Linux
~/.config/UnityHub/logs/info-log.json
macOS
~/Library/Application\ Support/UnityHub/logs/info-log.json
Windows
%UserProfile%\AppData\Roaming\UnityHub\logs\info-log.json

追加リソース