文档

Unity Engine

Unity Engine

收集 Android 设备上的性能数据

Connect an Android device to Unity and profile your application.
阅读时间4 分钟最后更新于 1 个月前

使用性能分析器 (Profiler) 可收集有关应用程序的性能数据。可以在 Unity 编辑器中收集运行模式下的性能数据。但是,为了获得有关应用程序的最准确数据,可以将性能分析器直接与网络上的 Android 设备连接。

先决条件

  • 如果使用了防火墙,请在防火墙的出站规则中开放端口
    54998
    至
    55511
    。这些是 Unity 用于远程性能分析的端口。
  • 禁用设备上的移动数据
  • 为 Android 设备和主机(运行 Unity 编辑器)设置同一子网,以便进行设备检测。

启用远程性能分析

要启用远程性能分析,请遵循以下步骤:
  1. 将设备连接 WiFi 网络。性能分析器使用本地 WiFi 网络将性能分析数据从您的设备发送给 Unity 编辑器。
  2. 通过线缆让设备与您的计算机连接。
  3. 打开构建配置文件 (Build profiles) 窗口(菜单:文件 (File) > 构建配置文件 (Build profiles)。
  4. 启用开发构建 (Development Build) 设置。
  5. 启用自动连接性能分析器 (Autoconnect Profiler) 设置。
  6. 选择构建并运行 (Build & Run)。
  7. 在设备上启动应用程序时,在 Unity 编辑器中打开性能分析器窗口(菜单:窗口 (Window) > 分析 (Analysis) > 分析器(Profiler))。
打开性能分析器窗口后,该窗口将填充来自应用程序的数据。’如果编辑器未自动连接设备,请在性能分析器窗口中选择目标选择 (Target Selection) 下拉菜单,然后选择适当的设备以手动启动性能分析器连接。
也可以将目标设备直接插入计算机,从而避免网络或连接问题。

使用 Android 调试桥进行性能分析

Android 设备支持通过 Android 调试桥 (adb) 进行性能分析。要进行 Android 调试桥 (adb) 性能分析,请遵循以下步骤:
  1. 确保设备处于开发模式并启用 USB 调试设置。
  2. 通过线缆让设备与计算机连接,并确保 adb 设备列表中显示了该设备。
  3. 打开构建配置文件 (Build profiles) 窗口(菜单:文件 (File) > 构建配置文件 (Build profiles)。
  4. 启用开发构建 (Development Build) 设置。
  5. 选择构建并运行 (Build & Run)。
  6. 在设备上启动应用程序时,打开分析器窗口(菜单:窗口 (Window) > 分析 (Analysis) > 分析器(Profiler))。
  7. 从目标选择 (Target Selection) 下拉菜单中选择
    AndroidProfiler(ADB@127.0.0.1:34999)
    。仅当所选目标为 Android 时,下拉菜单中的条目才会显示。

手动配置 Android 调试桥

选择构建并运行 (Build & Run) 时,编辑器会自动为应用程序创建 adb 隧道。如果要对另一应用程序进行性能分析,或者重新启动 adb 服务器,可以手动配置此隧道。
要手动配置隧道:
  1. 打开终端窗口或命令提示符。
  2. 输入以下代码:
    1. 通过 USB 线缆建立编辑器到 Android 的连接时需要:
      adb forward tcp:34999 localabstract:Unity-{insert bundle identifier here}
    2. 通过 USB 线缆建立 Android 到编辑器的连接时需要
      adb reverse tcp:34998 tcp:34999

其他资源