文档

Unity Engine

Unity Engine

Visual Studio C# 集成

Set up and use Microsoft Visual Studio as your default script editor for Unity.
阅读时间3 分钟最后更新于 1 个月前

Unity 通过用于 Visual Studio 的 Code Editor 包与 Microsoft Visual Studio 集成。安装 Unity 时预安装此包。如果在安装 Unity 时已安装了 Visual Studio,则 Unity 默认使用 Visual Studio 打开和编辑脚本。

包管理器 (Package Manager) 窗口中的 Visual Studio Editor

将 Visual Studio 设置为默认脚本编辑器

如果在安装 Unity 时已安装了 Visual Studio,或者在 Unity 安装过程中同时安装 Visual Studio,Unity 会自动使用 Visual Studio 作为其默认脚本编辑器。您可以将 Visual Studio 作为模块安装到现有的 Unity 安装中。有关更多信息,请参阅使用 Unity Hub 下载和安装编辑器与模块。
要手动设置默认脚本编辑器:
  • 在主菜单中转到编辑 (Edit) > 偏好设置 (Preferences)(macOS:Unity > 设置 (Settings)),然后打开偏好设置 (Preferences) 窗口。
  • 打开外部工具 (External Tools) 菜单。
  • 单击外部脚本编辑器 (External Script Editor) 下拉选单,然后选择 Microsoft Visual Studio。此选项的外观会根据已安装的 Microsoft Visual Studio 的版本而变化。

外部工具设置

A:外部脚本编辑器下拉选单,其中显示所选脚本编辑器的名称和版本。
B:与所选脚本编辑器集成的 Unity 包的名称和版本。
Unity 使用 Visual Studio 的 C# 编译器来编译脚本。将 Visual Studio Editor 包与 Visual Studio 结合使用时,Unity 和 Visual Studio 都会显示脚本中任何错误的详细信息。
Unity 会自动创建和维护 Visual Studio .sln 和 .csproj 文件。您可以在偏好设置 (Preferences) 窗口中的外部工具 (External Tools) 菜单中控制 Unity 是否为项目的某些元素生成 .csproj 文件,如上面的截屏所示。勾选或取消勾选复选框可切换 Unity 是否为给定选项生成 .csproj 文件。
每当参与者更改文件状态(例如编辑现有文件或创建新文件)时,Unity 都会在项目中重新生成 .sln 和 .csproj 文件。您也可以从 Visual Studio 向解决方案添加文件。Unity 会导入任何新文件,下次 Unity 再次创建项目文件时,便会使用包含的新文件进行创建。