검색 사용
Launch Search, run a query, and perform actions on the results in the Unity Editor.
읽는 시간 3분최근 업데이트: 한 달 전
검색을 사용하려면 아래를 진행해야 합니다.
검색 실행
몇 가지 방법으로 Search 창을 열 수 있습니다.
- Unity 메뉴에서 Edit > Search All 을 선택합니다.
- 에디터 창의 오른쪽 상단에 있는 돋보기 아이콘을 클릭합니다.
단축키:
단축키: | 함수: |
|---|---|
| Ctrl + K | 검색 열기 |
팁: 단축키 관리자에서 검색을 실행하는 데 사용할 키보드 단축기를 변경할 수 있습니다.
참고: 마지막으로 사용한 검색어가 검색창에 표시되며, 필터 설정의 마지막 변경 내용은 그대로 적용됩니다.
Search 창 계속 열어 두기
검색 항목을 선택한 후에도 창을 계속 열어 두려면 옵션 더 보기(⋮) 메뉴에서 Keep Open을 선택합니다.
검색 수행
검색을 수행하려면 검색 필드에 쿼리를 입력하십시오.
대다수의 검색 쿼리의 경우 Search All 창과 프로젝트와 함께 생성된 기본적인 에셋 인덱스를 사용하면 콘텐츠를 효율적으로 찾을 수 있습니다.
검색에 패키지를 포함하려면 옵션 더 보기(⋮) 메뉴에서 Show package results를 선택하십시오.
검색 결과 보기
검색 이력 내에서 이동하려면 Alt+↑(위쪽 화살표) 및 ↓(아래쪽 화살표)를 사용하거나, 왼쪽 창에서 저장된 검색을 선택합니다.
검색 결과 뷰 변경
리스트에서 썸네일이 있는 그리드 뷰로 변경하려면 크기 조절 슬라이더를 사용합니다. 검색 뷰를 변경하려면 Search 창의 오른쪽 하단에 있는 List 뷰 아이콘, Grid 뷰 아이콘, Table 뷰 아이콘을 사용합니다.

즐겨찾기 검색 결과 항목 추가
검색 결과 항목을 태그하여 다음번에 같은 검색을 수행할 때 더 쉽게 찾을 수 있도록 검색 리스트 최상단에 표시되게 하려면 해당 항목 옆의 별 모양 아이콘을 클릭합니다.
검색 상태
Search 창 하단에서 검색 시간과 결과 수를 확인하려면 옵션 더 보기(⋮) 메뉴에서 Show Status를 선택합니다.
검색 저장
검색을 저장하면 필요할 때 재사용할 수 있도록 유용한 검색을 보관할 수 있습니다. 검색을 개인 Unity에 저장하여 자신(사용자)이 사용하거나 프로젝트에서 작업하는 모든 사람이 검색할 수 있도록 에셋으로 저장합니다.
Unity의 개인 버전에 대한 검색을 저장하려면 다음 단계를 따르십시오.
-
검색을 생성합니다.
-
Search 창의 오른쪽 상단에 있는 저장 아이콘 드롭다운 메뉴를 클릭하고 Save User를 선택합니다.그러면 검색이 Search 창의 Saved Searches 패널에 추가됩니다.
-
변경한 후 다시 저장하려면 Saved Searches 창에서 검색을 강조 표시하고 Search 창의 오른쪽 상단에 있는 Save 드롭다운 메뉴에서 **Save <검색 이름>**을 선택합니다.
Saved Searches 패널에서 사용자 옆에 있는 저장 아이콘을 클릭할 수도 있습니다.
프로젝트에 검색을 추가하려면 다음을 수행합니다.
-
검색을 생성합니다.
-
Search 창의 오른쪽 상단에 있는 저장 아이콘 옆의 드롭다운 메뉴를 클릭하고 Save Project를 선택합니다.
-
Save search query 창에 파일 이름을 입력하고 Save를 선택합니다.그러면 검색이 Search 창의 Saved Searches 패널에 추가됩니다.
-
변경한 후 다시 저장하려면 Saved Searches 창에서 검색을 강조 표시하고 Search 창의 오른쪽 상단에 있는 Save 드롭다운 메뉴에서 **Save <검색 이름>**을 선택합니다.
Saved Searches 패널에서 프로젝트 옆에 있는 저장 아이콘을 클릭할 수도 있습니다.
저장된 검색 찾기
저장된 검색을 찾으려면 다음 단계를 따르십시오.
- Saved Searches 패널에서 돋보기 아이콘을 클릭합니다.
- 저장된 검색 이름 또는 이름의 일부를 입력합니다. 찾으면 패널에 표시됩니다.
동작
검색한 후에는 Preview Inspector 창 또는 옵션 더 보기(⋮)를 통해 검색이 반환한 항목에 대한 동작을 수행할 수 있습니다. 수행할 수 있는 동작은 항목 유형에 따라 다릅니다.
예를 들어 검색이 패키지를 반환하는 경우 패키지를 설치하거나 제거할 수 있습니다. 검색이 에셋을 반환하는 경우 계층 창에서 에셋을 선택하거나 열거나 강조 표시할 수 있습니다.
- 각 항목 유형에는 기본 동작이 있습니다.
- 일부 항목은 컨텍스트 메뉴를 통해 추가 동작을 지원합니다.
- 일부 항목은 드래그 앤 드롭 동작도 지원합니다.
여러 항목 유형에 수행할 수 있는 동작을 알아보려면 검색 제공자 페이지에서 개별 검색 필터에 대한 내용을 확인하십시오.
기본 동작
각 항목 유형에는 기본 동작이 있습니다.
항목의 기본 동작을 수행하려면 다음 중 하나를 수행하십시오.
- 항목을 더블 클릭합니다.
- 항목을 선택하고 Enter 키를 누릅니다.
참고: Preferences 페이지의 Search 섹션에서 기본 동작을 편집할 수 있습니다.
추가 동작
일부 항목은 Preview Inspector 메뉴에서 액세스할 수 있는 추가 동작을 지원합니다.
항목의 추가 동작 컨텍스트 메뉴에 액세스하려면 다음 중 하나를 수행하십시오.
- 항목을 오른쪽 클릭합니다.
- 항목 엔트리에서 옵션 더 보기(⋮)를 선택합니다.
Alt+Enter 단축키를 사용하여 컨텍스트 메뉴를 열지 않고도 선택한 항목에 대한 추가 동작을 수행할 수도 있습니다.