RenderDoc integration
Use the RenderDoc debugger to debug graphics on a frame by frame basis.
Read time 3 minutesLast updated 12 days ago
The Editor supports integrated launching and capture of the RenderDoc graphics debugger, for detailed frame introspection and debugging.
The integration is only supported for RenderDoc versions 0.26 or later, so if an earlier version is currently installed it is required that you update to at least version 0.26.
Loading RenderDoc
If a RenderDoc installation is detected, then at any time after loading the Editor you can right click on the tab for the Game View or Scene View and click the 'Load RenderDoc' option. This will reload the graphics device so you must save any changes, but afterwards RenderDoc will be ready to capture without having to restart the editor or build a standalone player.
Capturing a frame with RenderDoc
When a compatible version of RenderDoc is detected as loaded into the Editor, a new button will appear on the right side of the toolbar on the Game and Scene Views.

Capturing a frame with RenderDoc
Pressing this button will trigger a capture of the next frame of rendering for the view. If the RenderDoc tool UI has not been opened, a new instance will be launched to show the capture, and if it is already running the newest capture will automatically appear there. From there you can open the capture and debug using the tool.

List of frame captures in RenderDoc
Including shader debug information
By default to optimise the size of DirectX11 shaders, debugging information is stripped out. This means that constants and resources will have no names, and the shader source will not be available. To include this debugging information in your shader, include # pragma enable_d3d11_debug_symbols in your shader's block.
HLSLPROGRAMAlternative graphics debugging techniques
If you build a standalone player using D3D11, you can capture a frame and debug using the Visual Studio graphics debugger.
Configuring Android SDK in RenderDoc
When using RenderDoc to develop Android applications, ensure to configure the Android SDK correctly using one of the following ways:
Set RenderDoc to use the same SDK as Unity (recommended)
- In the RenderDoc window, go to Tools > Settings > Android.
- Under Android SDK root path, enter the path that Unity uses for Android SDK. You can find this path in the Unity Editor under Edit > Preferences > Android SDK Tools Installed with Unity.
Align ADB versions and paths between RenderDoc and Unity
If the Android SDK root path in RenderDoc settings isn't set, RenderDoc uses the path set for ADB in the environment variable.
PATH-
Find the ADB path set in thevariable.
PATH- Windows PowerShell:
Get-Command adb | Select-Object Path - Windows command prompt:
where adb
- Windows PowerShell:
-
Check the ADB version in Windows terminal:.
C:\[adb path from command output]\adb.exe version -
Find the ADB path that Unity uses. In the Unity Editor, go to Edit > Preferences > Android SDK Tools Installed with Unity.
-
Check the corresponding ADB version in Windows terminal:.
C:\[path to Android sdk platform-tools]\adb.exe version -
Compare the ADB versions that RenderDoc and Unity use. If they differ, choose one of the ADB locations and configure both tools to use the same path.