文档

Unity Engine

Unity Engine

日志文件参考

Locate Unity's log files which record messages, warnings, and errors that can help you understand the source of problems in your application.
阅读时间5 分钟最后更新于 1 个月前

Unity 为编辑器、Package Manager、许可、开发播放器和 Hub 生成日志文件。借助这些日志文件,您可以了解应用程序中发生任何问题的位置。
Unity 会将控制台 (Console) 窗口中的所有消息、警告和错误添加到日志文件中。如要将自己的消息添加到控制台 (Console) 窗口和日志,请使用 Debug 类。
不同操作系统存储日志文件的位置不同。此页面列出了默认存储位置,但也可以使用某些命令行参数来控制来控制 Unity 生成日志文件的时间和位置。有关更多信息,请参阅命令行参数文档。
**注意:**并非所有平台都支持这项功能。请参阅针对具体平台的文档以了解更多信息。
您可以从控制台窗口访问编辑器日志。为此,请打开控制台窗口(菜单:窗口 (Window)> 常规 (General)> 控制台 (Console)),然后在控制台窗口菜单中选择打开编辑器日志 (Open Editor Log)。
您可以使用操作系统的文件管理器应用程序访问其他日志。

Linux

日志类型

日志位置

编辑器
~/.config/unity3d/Editor.log
Package Manager
~/.config/unity3d/upm.log
许可客户端
~/.config/unity3d/Unity/Unity.Licensing.Client.log
许可审核
~/.config/unity3d/Unity/Unity.Entitlements.Audit.log

macOS

在 macOS 上,还可以通过 Console.app 实用程序访问 Unity 的日志

日志类型

日志位置

编辑器
~/Library/Logs/Unity/Editor.log
Package Manager
~/Library/Logs/Unity/upm.log
许可客户端
~/Library/Logs/Unity/Unity.Licensing.Client.log
许可审核
~/Library/Logs/Unity/Unity.Entitlements.Audit.log

Windows

在 Windows 上,Package Manager 和编辑器的日志放置在默认情况下未在 Windows 资源管理器中显示的文件夹中。要查看 AppData 文件夹,必须在 Windows 上启用隐藏项目 (Hidden Items) 设置。有关如何执行此操作的更多信息,请参阅 Microsoft 关于在 Windows 中查看隐藏文件和文件夹的文档。
在 Windows 上,默认情况下不存在标准输出流,因此必须使用已配置的有效
stdout
流来启动编辑器,就像 CI 系统中的子进程一样。如果指定
-
以将输出
 
发送到
stdout
,那么在控制台窗口中将看不到输出。

日志类型

日志位置

编辑器
%LOCALAPPDATA%\Unity\Editor\Editor.log
Package Manager用户帐户:
%LOCALAPPDATA%\Unity\Editor\upm.log

系统帐户:
%ALLUSERSPROFILE%\Unity\Editor\upm.log
许可客户端
%LOCALAPPDATA%\Unity\Unity.Licensing.Client.log
许可审核
%LOCALAPPDATA%\Unity\Unity.Entitlements.Audit.log
崩溃文件
%TMP%\CompanyName\ProductName\Crashes


**注意:**可使用
-crash-report-folder
命令行参数覆盖文件夹位置的位置。
要查看播放器日志,请打开控制台 (Console) 窗口(菜单:窗口 (Window)> 常规 (General)> 控制台 (Console)),然后在控制台窗口菜单中选择打开播放器日志 (Open Player Log)。您还可以导航到以下文件夹:

操作系统

播放器日志位置

Android要访问 Android 应用程序的播放器日志,请使用 Android logcat。有关更多信息,请参阅查看 Android 日志。
iOS可以使用 GDB 控制台,或者通过 XCode 中的管理器控制台来访问 iOS 设备的日志。有关设备日志的更多信息,请参阅 Apple 文档。
Linux
~/.config/unity3d/CompanyName/ProductName/Player.log
macOS
~/Library/Logs/Company Name/Product Name/Player.log


**注意:**您还可以使用 Console.app 实用程序查找日志文件。
通用 Windows 平台
%USERPROFILE%\AppData\Local\Packages\<productname>\TempState\UnityPlayer.log
WebUnity 会将日志输出写入到浏览器的 JavaScript 控制台。
Windows
%USERPROFILE%\AppData\LocalLow\CompanyName\ProductName\Player.log

Unity Hub 日志位置

您可以使用操作系统的文件管理器应用程序访问 Hub 日志。您还可以从 Hub 中访问这些日志。有关更多信息,请参阅 Hub 文档。

操作系统

播放器日志位置

Linux
~/.config/UnityHub/logs/info-log.json
macOS
~/Library/Application\ Support/UnityHub/logs/info-log.json
Windows
%UserProfile%\AppData\Roaming\UnityHub\logs\info-log.json

其他资源