# 로그 파일 레퍼런스

> Locate Unity's log files which record messages, warnings, and errors that can help you understand the source of problems in your application.

Unity는 에디터, 패키지 관리자, 라이선스 부여, 개발 플레이어 및 Hub용 로그 파일을 생성합니다. 이러한 로그 파일을 사용하여 애플리케이션에서 발생한 문제의 위치를 파악할 수 있습니다.

Unity는 [콘솔 창](/engine/6000.0/manual/unity-editor/using-the-editor/console.md)의 모든 메시지, 경고 및 오류를 로그 파일에 추가합니다. 자체 메시지를 콘솔 창과 로그에 추가하려면 [Debug 클래스](/engine/6000.0/manual/scripting/debugging-and-diagnostics/class-debug.md)를 사용합니다.

각 운영체제는 로그 파일을 서로 다른 위치에 저장합니다. 기본 위치는 이 페이지에 나와 있지만 특정 커맨드 라인 인자를 사용하여 Unity가 로그 파일을 생성하는 시점과 위치를 제어할 수도 있습니다. 자세한 내용은 [커맨드 라인 인자](/engine/6000.0/manual/unity-editor/editor-features/command-line-arguments/editor.md) 기술 자료를 참조하십시오.

**참고:** 일부 플랫폼에서는 이 기능을 지원하지 않습니다. 자세한 내용은 [플랫폼별 정보](/engine/6000.0/manual/platform-specific.md) 기술 자료를 참조하십시오.

## 에디터 관련 로그 위치##editor-related-log-locations

콘솔 창에서 에디터 로그에 액세스할 수 있습니다. 이렇게 하려면 콘솔 창(**메뉴: Window > General > Console**)을 선택하고 콘솔 창 메뉴에서 **Open Editor Log**를 선택합니다.

운영체제의 파일 관리자 애플리케이션을 사용하여 다른 로그에 액세스할 수 있습니다.

### Linux##linux

| **로그 유형**           | **로그 위치**                                              |
| ------------------- | ------------------------------------------------------ |
| **에디터**             | `~/.config/unity3d/Editor.log`                         |
| **Package manager** | `~/.config/unity3d/upm.log`                            |
| **라이선스 부여 클라이언트**   | `~/.config/unity3d/Unity/Unity.Licensing.Client.log`   |
| **라이선스 부여 감사**      | `~/.config/unity3d/Unity/Unity.Entitlements.Audit.log` |

### macOS##macos

macOS에서는 Console.app 유틸리티를 통해 Unity의 로그에 액세스할 수도 있습니다.

| **로그 유형**           | **로그 위치**                                           |
| ------------------- | --------------------------------------------------- |
| **에디터**             | `~/Library/Logs/Unity/Editor.log`                   |
| **Package manager** | `~/Library/Logs/Unity/upm.log`                      |
| **라이선스 부여 클라이언트**   | `~/Library/Logs/Unity/Unity.Licensing.Client.log`   |
| **라이선스 부여 감사**      | `~/Library/Logs/Unity/Unity.Entitlements.Audit.log` |

### Windows##windows

Windows에서 패키지 관리자와 에디터 로그는 기본적으로 Windows 탐색기의 숨겨진 폴더에 저장됩니다. AppData 폴더를 보려면 Windows에서 Hidden Items 설정을 활성화해야 합니다. 이를 수행하는 방법에 대한 자세한 내용은 [Windows에서 숨겨진 파일 및 폴더 보기](https://support.microsoft.com/en-us/windows/view-hidden-files-and-folders-in-windows-97fbc472-c603-9d90-91d0-1166d1d9f4b5)에 대한 Microsoft 기술 자료를 참조하십시오.

Windows에서는 기본적으로 표준 아웃스트림이 존재하지 않으므로 CI 시스템의 자식 프로세스로서 구성된 유효한 `stdout` 스트림으로 에디터를 실행해야 합니다. 출력을` ``stdout`으로 보내는 `-`를 지정하면 콘솔 창에 출력이 표시되지 않습니다.

| **로그 유형**           | **로그 위치**                                                                                                |
| ------------------- | -------------------------------------------------------------------------------------------------------- |
| **에디터**             | `%LOCALAPPDATA%\Unity\Editor\Editor.log`                                                                 |
| **Package manager** | 사용자 계정: `%LOCALAPPDATA%\Unity\Editor\upm.log`시스템 계정: `%ALLUSERSPROFILE%\Unity\Editor\upm.log`            |
| **라이선스 부여 클라이언트**   | `%LOCALAPPDATA%\Unity\Unity.Licensing.Client.log`                                                        |
| **라이선스 부여 감사**      | `%LOCALAPPDATA%\Unity\Unity.Entitlements.Audit.log`                                                      |
| **Crash files**     | `%TMP%\CompanyName\ProductName\Crashes`**참고:** `-crash-report-folder` 커맨드 라인 인자를 사용하여 폴더 위치를 덮어쓸 수 있습니다. |

## 플레이어 관련 로그 위치##player-related-log-locations

플레이어 로그를 보려면 콘솔 창(**메뉴: Window > General > Console**)을 열고 콘솔 창 메뉴에서 **Open Player Log**를 선택합니다. 다음 폴더로 이동할 수도 있습니다.

| **운영체제**             | **플레이어 로그 위치**                                                                                                                                                                                                                                                                         |
| -------------------- | -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- |
| **Android**          | Android 애플리케이션의 플레이어 로그에 액세스하려면 [Android 로그캣](https://developer.android.com/studio/command-line/logcat)을 사용합니다. 자세한 내용은 [Android 로그 보기](/engine/6000.0/manual/platform-specific/android/developing/testing-and-debugging/debugging-on-an-android-device.md#view-android-logs)를 참조하십시오. |
| **iOS**              | GDB 콘솔 또는 XCode를 통한 Organizer Console을 사용하여 iOS 기기 로그에 액세스합니다. 기기 로그에 대한 자세한 내용은 [Apple 기술 자료](https://developer.apple.com/documentation/xcode/acquiring-crash-reports-and-diagnostic-logs)를 참조하십시오.                                                                                   |
| **Linux**            | `~/.config/unity3d/CompanyName/ProductName/Player.log`                                                                                                                                                                                                                                 |
| **macOS**            | `~/Library/Logs/Company Name/Product Name/Player.log`**참고:** Console.app 유틸리티를 사용하여 로그 파일을 찾을 수도 있습니다.                                                                                                                                                                                 |
| **유니버설 Windows 플랫폼** | `%USERPROFILE%\AppData\Local\Packages\<productname>\TempState\UnityPlayer.log`                                                                                                                                                                                                         |
| **웹**                | Unity는 로그 출력을 [브라우저의 JavaScript 콘솔](/engine/6000.0/manual/platform-specific/webgl/develop/debugging.md)에 작성합니다.                                                                                                                                                                        |
| **Windows**          | `%USERPROFILE%\AppData\LocalLow\CompanyName\ProductName\Player.log`                                                                                                                                                                                                                    |

## Unity Hub 로그 위치##unity-hub-log-locations

운영체제의 파일 관리자 애플리케이션을 사용하여 Hub 로그에 액세스할 수 있습니다. Hub 내에서 이러한 로그에 액세스할 수도 있습니다. 자세한 내용은 [Hub 기술 자료](https://docs.unity3d.com/hub/manual/Help.html)를 참조하십시오.

| **운영체제**    | **플레이어 로그 위치**                                               |
| ----------- | ------------------------------------------------------------ |
| **Linux**   | `~/.config/UnityHub/logs/info-log.json`                      |
| **macOS**   | `~/Library/Application\ Support/UnityHub/logs/info-log.json` |
| **Windows** | `%UserProfile%\AppData\Roaming\UnityHub\logs\info-log.json`  |

## 추가 리소스##additional-resources

* [콘솔 창](/engine/6000.0/manual/unity-editor/using-the-editor/console.md)
* [스택 추적 로깅](/engine/6000.0/manual/scripting/debugging-and-diagnostics/stack-trace.md)
