# Console ウィンドウ

> View error messages, warnings, and debug logs from your scripts and the Unity Editor.

**Console** ウィンドウには、エラー、警告、およびエディターで生成されるその他のメッセージが表示されます。これらのエラーと警告は、スクリプトのコンパイルエラーなど、プロジェクト内の問題を見つけるために役立ちます。また、欠落しているメタファイルの置き換えなど、エディターで自動的に行われたアクションについても警告が表示されます。このようなアクションによって、プロジェクトの別の場所で問題が発生する可能性があるためです。

プロジェクトのデバッグには、[Debug](/engine/6000.0/manual/scripting/debugging-and-diagnostics/class-debug.md) クラスを使用して独自のメッセージをコンソールに出力すると便利です。例えば、ある時点でスクリプトの変数の値を印刷しておくと、その変化を確認できます。

このページでは、Console ウィンドウでの作業時に使用できるオプションと、特定のキーワードで検索してメッセージをフィルター処理する方法について説明します。

## Console ウィンドウのインターフェース

Unity のメインメニューからコンソールを開くには、**Window** > **General** > **Console** の順に選択します。


**Frame:**
![](/api/media?file=/engine/6000.0/media/images/Console.png)

**A**. Console **ツールバー**には、メッセージの表示を制御するオプションと、メッセージを[検索してフィルタリングする](#search)オプションがあります。

**B**. Console ウィンドウのメニューには、[ログファイルを開く](#log-file)ためのオプション、リスト内の[各メッセージの表示量を制御する](#line-count)ためのオプション、スタックトレースを設定するためのオプションがあります。

**C**. Console リストには、ログに記録された各メッセージのエントリーが表示されます。メッセージを選択すると、そのテキスト全体が詳細エリアに表示されます。このエリアに表示する各メッセージの行数を選択できます。[行数の調整](#line-count)については下記を参照してください。

**D**. 詳細エリアには、選択したメッセージの全文が表示されます。スタックトレースを有効にすると、コードファイル内の特定の行への参照が、詳細エリアにクリック可能なリンクとして表示されます。

## Console ツールバーのオプション

Console ウィンドウのツールバーには、メッセージの表示方法やメッセージの検索とフィルタリングを制御するオプションがあります。

| **オプション**:              |                       | **機能**:                                                                                                                                                                                                                                                                   |
| ----------------------- | --------------------- | ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- |
| **Clear**               |                       | コードからのメッセージはすべて削除しますが、コンパイラーからのエラーメッセージは保持します。消去オプションのあるドロップダウンメニューを開きます。                                                                                                                                                                                                 |
|                         | Clear On Play         | 再生モードに入るたびにコンソールを自動的にクリアします。                                                                                                                                                                                                                                              |
|                         | Clear on Build        | プロジェクトをビルドするときにコンソールをクリアします。                                                                                                                                                                                                                                              |
|                         | 再コンパイル時に消去            | プロジェクトを再コンパイルするときにコンソールを消去します。                                                                                                                                                                                                                                            |
| **Collapse**            |                       | 繰り返し発生するエラーメッセージの最初のインスタンスのみを表示します。これは、各フレームの更新で生じることのあるランタイムエラー (null 参照など) に役立ちます。                                                                                                                                                                                      |
| **Error Pause**         |                       | スクリプトから [`Debug.LogError`](/engine/6000.0/script-reference/unity-engine/debug/log-error.md) を呼び出すたびに再生を一時停止します。実行中の特定のポイントで、この再生の一時停止を利用し、シーンを調べることができます。このオプションは、スクリプトから [`Debug.Log`](/engine/6000.0/script-reference/unity-engine/debug/log.md) を呼び出した場合は、再生を一時停止しません。 |
| **\[Attach-to-Player]** |                       | ドロップダウンメニューを開き、リモートデバイスで実行されている開発ビルドへの接続を選択して、そのプレイヤーのログをコンソールに表示します。このオプションには、ターゲット開発ビルド (コンソールウィンドウに表示されるログのビルド) の名前のラベルが付けられます。コンソールは、リモートビルドに接続されていない場合は **Editor** というラベルが付けられ、Console ウィンドウに表示されるログがローカルの Unity エディターからのものであることを示します。                               |
|                         | Player Logging        | コンソールがリモート開発ビルドに接続されている場合は、ビルドのプレイヤーのロギングが有効になります。このオプションを無効にすると、ロギングが一時停止されますが、コンソールはターゲットビルドに接続されたままになります。このオプションを無効にすると、このドロップダウンメニューの残りのオプションも非表示になります。**Player Logging** の下にリストされているビルドを選択すると、Console ウィンドウにログが表示されます。                                               |
|                         | Editor                | Console がリモートの**開発ビルド**に接続されている場合は、このオプションを選択すると、リモートビルドからのログではなくローカルの Unity Player からのログが表示されます。                                                                                                                                                                         |
|                         | `<Enter IP>`          | **Enter Player IP** ダイアログが開き、リモートデバイス上の開発ビルドの IP アドレスを指定できます。ビルドに接続するには、ダイアログで **Connect** を選択し、ドロップダウンメニューの下部にある開発ビルドのリストに追加します。                                                                                                                                         |
|                         | \[DEVELOPMENT BUILDS] | 使用可能な開発ビルドをリストします。これには、自動検出されたビルドと、**Enter IP** オプションを使用してユーザーが追加したビルドが含まれます。                                                                                                                                                                                             |

## コンソール出力の検索とフィルタリング

コンソールの検索フィールドを使うと、特定のキーワードでコンソールのメッセージを検索できます。検索キーワードを入力すると、メッセージはフィルターされ、一致するテキストを含むメッセージのみが表示されます。コンソールでは、検索したテキストが、ヒットしたメッセージの表示されている部分にある場合に限り、最初の一致部分のみハイライトされます (後述の[行数の調整](#line-count)を参照)。


**“name” という語を検索すると、各メッセージの最初の一致が強調表示されます。:**
![](/api/media?file=/engine/6000.0/media/images/ConsoleSearch.png)

コンソールのメッセージに表示されるもの (数字や特殊文字などを含む) はすべて検索できます。例えば、コンソールでメッセージがログに記録された時間を検索できます。

検索では、検索バーに入力した内容と完全に一致するものが検索されます。2 つの異なる用語の同時検索や、一般的な検索エンジン演算子の使用はできません。

コンソールメッセージはタイプでフィルターすることもできます。検索フィールドの横にあるボタンをクリックして切り替えます。

| **ボタン**                                                                                                    | **機能**                                         |
| ---------------------------------------------------------------------------------------------------------- | ---------------------------------------------- |
| &#xA;**Frame:**&#xA;![](/api/media?file=/engine/6000.0/media/images/ConsoleFilterMessage.png)**メッセージスイッチ** | コンソールのメッセージ数を表示します。クリックすると、メッセージを表示または非表示にします。 |
| &#xA;**Frame:**&#xA;![](/api/media?file=/engine/6000.0/media/images/ConsoleFilterWarning.png)**警告スイッチ**    | コンソール内の警告数を表示します。クリックすると警告を表示または非表示にします。       |
| &#xA;**Frame:**&#xA;![](/api/media?file=/engine/6000.0/media/images/ConsoleFilterError.png)**エラースイッチ**     | コンソール内のエラー数を表示します。クリックすると、エラーが表示または非表示になります。   |

## 行数の調整

各コンソールのエントリーは最大 10 行まで可能です。

リストの各エントリーで表示する行数を制御するには、Console メニューボタンをクリックし、メニューから **Log Entry** > **\[X] Lines** を選択します。ここで、**\[X]** はエントリーごとの表示行数です。


**ログエントリーの行数:**
![](/api/media?file=/engine/6000.0/media/images/ConsoleAdjustLineCount.png)

行数を増やすと、各エントリのテキストがより多く表示されますが、同時に表示できるエントリ数は減ります。行数は、常にメッセージ全文を検索するコンソールの検索機能には影響しません。一致するテキストが非表示の行にある場合、検索結果にメッセージが返されますが、一致するテキストを表示または強調表示するために展開されることはありません。詳細エリアにメッセージの全文が表示されますが、一致するテキストはハイライトされません。

## Stack Trace Logging

Unity コンソールのメッセージとログファイルに、詳細なスタックトレース情報を加えることができます。スタックトレース情報の量は、[スタックトレースロギング](/engine/6000.0/manual/scripting/debugging-and-diagnostics/stack-trace.md)設定を使用してコントロールできます。

## コンソールからログファイルを開く

Unity やコードによって Console ウィンドウに書き込まれるものはすべて、[ログファイル](/engine/6000.0/manual/scripting/debugging-and-diagnostics/log-files.md)にも書き込まれます。ログファイルは Cnsole ウィンドウのメニューから開くことができます。**Open Player Log** または **Open Editor Log** を選択します。
